WP Security CheckVulnerability data as of November 4, 2026

Vulnerability alerts / November 2, 2026

Vulnerability in Welcart e-Commerce — CVE-2026-120597

LowSeverity
CVSS 2.1
0.3%Estimated exploit probability
EPSS
10,000+ sitesInstalls
Not publishedFixed in

What to do now

No fix has been published yet. Consider disabling Welcart e-Commerce for now, or moving to an alternative.

Affected: Welcart e-Commerce (plugin, usc-e-shop)

Check: The plugin on wordpress.org / Our record for Welcart e-Commerce

What the vulnerability is

A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

This description is reproduced verbatim from the public vulnerability record.

Sources

See other alerts