WP Security CheckVulnerability data as of November 1, 2026

Vulnerability alerts / October 31, 2026

Vulnerability in Uncanny Toolkit for LearnDash — CVE-2026-119096

CriticalSeverity
CVSS 9.8
0.5%Estimated exploit probability
EPSS
20,000+ sitesInstalls
3.8.3Fixed in

What to do now

Update Uncanny Toolkit for LearnDash to 3.8.3 or later.

Affected versions

  • Everything up to and including 3.8.2

Affected: Uncanny Toolkit for LearnDash (plugin, uncanny-learndash-toolkit)

Check: The plugin on wordpress.org / Our record for Uncanny Toolkit for LearnDash

What the vulnerability is

The Uncanny Toolkit for LearnDash plugin for WordPress is vulnerable to Authentication Bypass in versions up to, and including, 3.8.2 via the `email` parameter of the `uo_login_action()` function. This is due to a parser-differential flaw in which the plugin's account-verification gate resolves the submitted `email` value using the raw, unsanitized string passed to `get_user_by()`, while the subsequent `wp_signon()` call relies on WordPress core's internal `sanitize_user()` to strip appended junk characters — causing the gate lookup to fail and be skipped entirely while the real account is still resolved and authenticated. This makes it possible for unauthenticated attackers to log in to unverified or administrator-suspended accounts whose credentials they already possess, obtaining a valid `wordpress_logged_in` session cookie and defeating the plugin's account-approval and account-suspension controls. The nonce required to reach the handler is freely obtainable in the same request from the unauthenticated `ult-refresh-nonce` endpoint, making exploitation trivial for any attacker with network access to the site and knowledge of a target account's credentials.

This description is reproduced verbatim from the public vulnerability record.

Sources

See other alerts