WP Security CheckVulnerability data as of October 29, 2026

Vulnerability alerts / October 28, 2026

Vulnerability in Page Builder by SiteOrigin — CVE-2026-110507

MediumSeverity
CVSS 4.3
0.2%Estimated exploit probability
EPSS
400,000+ sitesInstalls
2.38.0Fixed in

What to do now

Update Page Builder by SiteOrigin to 2.38.0 or later.

Affected versions

  • Everything before 2.38.0

Affected: Page Builder by SiteOrigin (plugin, siteorigin-panels)

Check: The plugin on wordpress.org / Our record for Page Builder by SiteOrigin

What the vulnerability is

The Page Builder by SiteOrigin plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to 2.38.0. This makes it possible for authenticated attackers, with contributor-level access and above, to extract sensitive user or configuration data.

This description is reproduced verbatim from the public vulnerability record.

Sources

Part of this record comes from Wordfence Intelligence. Original: https://www.wordfence.com/threat-intel/vulnerabilities/id/e66c5a82-9647-46b0-ab3f-b2cd4740bb10
Copyright 2012-2026 Defiant Inc. / Full license text

This page is compiled automatically from public databases. Accuracy is not guaranteed; confirm against the vendor advisory before acting.

See other alerts